Android studio 操作一直报错,请大神指教?[复制链接]

我自从安装Android Studio 开发以来,一直报错,到现在还不能写代码,不能运行,我请求大神做私人指导,我可以付费,感谢!
如问题
install repository and sync project show in file
show in project structure dialog

gradle project sync failed.basic function (e.g.editing debugging)will not work properly

愚速 2301查看 · 15回复 · 2018-3-7 17:13 有用(0
共15个回答
lilongfei0504 2018-3-8 08:45 回复

我觉得你贴的信息不全,请把全部的错误都贴出来

愚速 2018-3-8 10:52 回复
lilongfei0504 发表于 2018-3-8 08:45
我觉得你贴的信息不全,请把全部的错误都贴出来

Failed to resolve:com.android.support:appcompat-v7:27.0.0-alpha1
install repository and sync project show in file
show in project structure dialog
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:27.0.0-alpha1'
}

gradle project sync failed.basic function (e.g.editing debugging)will not work properly
lilongfei0504 2018-3-8 13:09 回复

compile 'com.android.support:appcompat-v7:27.0.0-alpha1' 意思是你的sdk没有这个版本,而且alpha是测试版的意思,正式项目不要用这个。

解决办法是修改一下27.0.0-alpha1,在你输入的时候,开发工具是有提示的,另外打开你的SDK manager,update下tools和extras下面工具包,

独孤月 2018-3-8 14:18 回复

AS的配置比较麻烦一点 至于SDK 可以找找国内的镜像网站 现在VPN有的也翻不过墙

随风而逝无痕 2018-3-8 22:48 回复

SDK版本和ADT匹配下试试看

虔诚的小白 2018-3-9 09:06 回复

有截图么

愚速 2018-3-10 21:53 回复

不晓得怎么上传截图
愚速 2018-3-10 21:53 回复
独孤月 发表于 2018-3-8 14:18
AS的配置比较麻烦一点至于SDK可以找找国内的镜像网站现在VPN有的也翻不过墙 ...

我一直配置错误,解决一个错误,下一个又出来了,请问有什么办法吗?
愚速 2018-3-10 21:55 回复
lilongfei0504 发表于 2018-3-8 13:09
compile'com.android.support:appcompat-v7:27.0.0-alpha1'意思是你的sdk没有这个版本,而且alpha是测试版 ...

我感觉我安装的tools 和extras 安装是不完整的,跟网上介绍的,好像不一样。
独孤月 2018-3-12 10:20 回复
愚速 发表于 2018-3-10 21:53
我一直配置错误,解决一个错误,下一个又出来了,请问有什么办法吗?

最好的办法就是多配几次    或者直接换IDear     其实不一定非要用AS     还有很多的环境都支持Android编译框架的搭建
12下一页
需要登入后才可以评论 登录 | 立即注册