Android Studio 项目导入的正确姿势 [复制链接]

2019-4-16 10:05
ceshishangchuan 阅读:195 评论:0 赞:0
Tag:  

导入其他人的项目对于咱们开发人员来说是一个基础,可有些时候导入了10分钟20分钟甚至更久死活一直导不进来。这里就教大家一个轻松便捷的导入方法,顺便跟大家探讨一下导入程序的正确姿势。

第一步,首先查看根目录的build.gradle文件

拿到项目之后先不着急打开导入,咱们先查看一下根目录的build.gradle文件查看。

  • classpath 'com.android.tools.build:gradle的版本和你本地的是否一致,如果不一致,直接修改成你的Android Studio版本即可

  • 如果你的Android Studio使用的是2.x的版本,而要导入的项目恰巧使用的3.0的版本,这时候就需要注释掉repositories{}中的google()方法。

  • 如果你是从Github下载的项目,可能会带有作者发版时的配置,也需要将其注释掉:

完整的注释步骤如下:

apply from: "dependencies.gradle"

buildscript {
    repositories {
        jcenter()
        // 第二步,注释
       // google()
    }
    dependencies {
        // 第一步,修改版本号
        classpath 'com.android.tools.build:gradle:2.2.2'

    // 第三步 ,注释不相关的版本发布
        // classpath 'com.jfrog.bintray.gradle:gradle-bintray-plugin:1.4'
        // classpath 'com.github.dcendents:android-maven-gradle-plugin:1.4.1'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
        // 第二步,注释
       // google()
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

注意,一定要注意不要轻易删除某些东西。

第二步,查看gradlewrappergradle-wrapper.properties文件。这里主要是看gradle版本信息

#Thu May 25 13:52:26 CST 2017
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-2.14.1-all.zip

我这里使用的2.14.1,你们直接改成你们对应版本即可。

到这里最主要且必须的两步都做完了,下面就可以导入项目了,导入之后还是会报各种错误,不要着急咱们慢慢来。

第三步,打开(导入)项目,查看app下的build.grade文件,并统一修改自己的版本号

Picture

因为Google在3.0的时候废弃了compile,改为implementation和api了,具体区别可以自行百度。如果你要导入的项目是3.X,而你的版本是Android Studio 2.X,那么就需要把所有implementation改回compile。

如以下:
    3.0之前
    compile 'io.reactivex.rxjava2:rxandroid:2.0.1'
    compile 'io.reactivex.rxjava2:rxjava:2.1.3'

    3.0之后
    implementation 'io.reactivex.rxjava2:rxandroid:2.0.1'
    implementation 'io.reactivex.rxjava2:rxjava:2.1.3'
除以上之外,还有以下:

 androidTestCompile(前)  
 androidTestImplementation(后)  


 testCompile(前)
 testImplementation (后)

如果你的项目是从Github上下载的,你需要注释掉作者发版的信息。这里你可以对比你之前可以运行的项目的build.gradle文件,把不相关的文件统统注释掉,注意依然是注释哦。

到这里就可以build一下了,可能还会有报错,哪里报错咱们再接着修改哪里。

遇到的问题

Failed to resolve:com.android.support:appcompat-v7:报错处理

Picture

这里是因为你的sdk版本低于27版本,简单粗暴的方法是直接修改成你的sdk版本即可。对于该类错误,可参考Failed to resolve:com.android.support:appcompat-v7:报错处理(图片也来源于此博客)

app:transformClassesWithJarMergingForDebug 重复依赖的报错处理

当使用maven导入依赖时,可能会出现不同的依赖包含了同一个jar,在编译期间不会报错。可一旦run app的时候,就会报

Error:Execution failed for task ':app:transformClassesWithJarMergingForDebug'.
> com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: xxx.class

解决的方法是在引入依赖的时候把相同的jar去除掉。具体可以参照Android Studio 中如何解决重复依赖导致的app:transformClassesWithJarMergingForDebug

In <declare-styleable> FontFamilyFont, unable to find attribute android:font的报错处理

Picture

这是因为 compileSdkVersion 和buildToolsVersion 的版本不对应,所以才会出现这种问题,解决办法就是需要改成对应的版本。具体参照In FontFamilyFont, unable to find attribute android:font的报错处理

错误Conflict with dependency 'com.google.code.findbugs:jsr305' 解决方法

具体错误是:

Warning:Conflict with dependency 'com.google.code.findbugs:jsr305'. Resolved versions for app (3.0.1) and test app (2.0.1) differ. See http://g.co/androidstudio/app-test-app-conflict for details.

解决办法是在项目的app根目录中build.gradle中加入

android {
    configurations.all {
        resolutionStrategy.force 'com.google.code.findbugs:jsr305:1.3.9'
    }
}

这是我目前总结的关于导入项目时的方法和错误,希望大家可以积极留言说下自己导包的姿势和补充自己遇到的问题。如果对大家有帮助,还希望大家点赞支持或留言。

分享到:
我来说两句
facelist
您需要登录后才可以评论 登录 | 立即注册
所有评论(0)

领先的中文移动开发者社区
18620764416
7*24全天服务
意见反馈:1294855032@qq.com

扫一扫关注我们

Powered by Discuz! X3.2© 2001-2019 Comsenz Inc.( 粤ICP备15117877号 )