android中导入低版本project可能会遇到的编译问题

2
回复
54891
查看
[复制链接]

193

主题

225

帖子

26

安币

初级码农

Rank: 1

发表于 2012-4-15 14:16:42 | 显示全部楼层 |阅读模式

使用高版本的SDK后再导入以前用低版本的project时,会遇到一些兼容性的问题。

    (1)Unable to resolve target 'android-5'

   因为本机中现在使用的是2.1的SDK,API的版本是7;而导入的工程使用的是2.0开发的,其API版本是5。

   需要将default.properties中的target=android-5改为target=android-7就好了。

   但要注意,也要同步将AndroidManifest.xml中的<uses-sdk android:minSdkVersion="5" />改为<uses-sdk android:minSdkVersion="7" />,否则编译中会警告提示使用的版本过低。

   (2)以上完成后,编译中又出现一个新的错误:Conversion to Dalvik format failed with error 1

   这个与加载的SDK有关,通过“右键选择工程build path -> configure build path... -> library发现导入的JARs中除了一个Android 2.1-update1外还有一个同路径下的文件夹item,将其移除,clean一下再编译就没问题了。


1

主题

13

帖子

175

安币

程序猿

Rank: 2

发表于 2012-5-11 17:07:26 | 显示全部楼层
确实出现过,而且我只改了第一项,不过编译是可以,但是中文出现了乱码

0

主题

78

帖子

63

安币

程序猿

Rank: 2

发表于 2012-6-6 16:19:56 | 显示全部楼层
遇到过这样的问题。。。{:Skateboard:}
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

领先的中文移动开发者社区
18620764416
7*24全天服务
意见反馈:1294855032@qq.com

扫一扫关注我们

Powered by Discuz! X3.2© 2001-2019 Comsenz Inc.( 粤ICP备15117877号 )